ildeposito
ildeposito
Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 MSTS / ORTS
 MSTS and ORTS scenari e activity
 spiegazione su OR
 New Topic  Reply to Topic
 Printer Friendly
Next Page
Author Previous Topic Topic Next Topic
Page: of 3

randrett
Starting Member

Italy
26 Posts

Posted - 22/03/2022 :  21:22:54  Show Profile  Reply with Quote
Ciao Renzo,
scusa se ti disturbo, sono Roberto (randrett), ti ricordi, qualche anno fa ci siamo sentiti, poi varie vicissitudini mi hanno portato a lasciare la simulazione per altri interessi, ora ho qualche ora di tempo in più e mi sono messo a smanettare ancora; solo che nel frattempo è arrivata la novità di Open Rails e io mi sono perso un pò tutto, cmq a leggere i forum qualcosa ho fatto funzionare (p.e. un path so come si costruisce), ma ti devo dire la verità con l'activity editor trovo qualche difficoltà.
Allora ho pensato di riesumare per OR qualche activity che avevo fatto in TS, ho provato e a forza di tentativi un'activity (Cisterne per Fabriano sull'Ancona:Fabriano Marche1)è risultata perfetta anche su OR (naturalmente cambiando i rotabili, per attualizzarli un pò).
Adesso, io mi trovo che vorrei riesumare l'activity Soccorso a Pontedera, sulla tua Fi-Pi-Li-Si 2007, e mi trovo un problemino:
il player parte da un tronchino e va ad agganciare un merci con e652 guasta, retrocede, aggancia e attende via libera perchè da Pisa è arrivato un REG che ha precedenza.
In ts avevo fatto così per fare il sorpasso, al Reg avevo anticipato l'orario di partenza rispetto al player di 5 secondi (con un wait point sulla path) e in TS funzionava
(in TS era l'orario di partenza che dava priorità, sia al player che a un AI, sbaglio?) e funziona ancora, in OR mi dà semaforo verde al mio player e via impedita al REG, quindi niente sorpasso.
Sicuramente c'è un mio errore, si ma dove?
Mi riscuso ancora per il disturbo, ti ringrazio già da adesso se vorrai rispondermi e ti saluto.
Roberto


AndrE424
Starting Member

Italy
40 Posts

Posted - 23/03/2022 :  09:37:48  Show Profile  Reply with Quote
Ciao,
io in questo caso proverei con due soluzioni:
- sul tuo percorso metti due Reverse Point per far scattare il rosso al tuo treno e dare il via libera al Regionale
- inserisci davanti a te un treno fantasma che tanga a via impedita il tuo path mettendogli un Wait point con orario di partenza da te definito. (es. l'attività inizia alle 12. Tu fai partire anche subito il treno fantasma e matti WP che lui si tolga alle 12.10. Tu completi l'aggancio alle 12.05 e vedrai il segnale rosso. Il regionale ha partenza 12.08, se tutto va come deve andare lui avrà il via libere. Alle 12.10 il TF si toglierà e ti si aprirà il segnale anche a te).

Ovviamente il TF devi metterlo appena oltre il tuo segnale di partenza e il suo path non deve interferire con quello del Regionale.

Spero di esserti stato utile
Ciao


Andrea V.
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  11:48:15  Show Profile  Reply with Quote
grazie Andrea,
le soluzioni da te indicate le ho già provate, ma non funziona, piuttosto, dopo aver comparato in OR 3 activities, 2 che vanno ok e l'incriminata, trovo differenza nel timetable: in quelle che vanno il timetable riporta gli orari sia del player che degli AI, in quella che non va nel timetable appare solo l'orario del player.
Il problema è che non so come editare questo timetable, nè dove va posizionato il file generato.
Grazie cmq e ciao a tutti
Roberto
Go to Top of Page

AndrE424
Starting Member

Italy
40 Posts

Posted - 23/03/2022 :  12:25:05  Show Profile  Reply with Quote
Ciao,
ma usi TSRE5 o l'activity editor di Microsoft?

Il timetable sia del player che dei treni AI li puoi editare a mano nel file dell'attività o del service. Cosa che va fatto quando si creano attività a cavallo della mezzanotte.

I treni Ai come il player devono per forza avere un tabella oraria, soprattutto se sono dei passeggeri. OR, in automatico ti mette il segnale di partenza della fermata al rosso.

In base a cosa usi come programma per generare l'attività posso spiegarti come editare il tempo.

Ciao
Andrea

Andrea V.
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  12:32:40  Show Profile  Reply with Quote
ciao Andrea,
allora io uso AE di TS, perchè quello conosco, il TSRE5 è ancora ostico per me, modifico e salvo le activities in MSTS e le copio pari pari nella directory train simulator per Open Rails (su altro PC);
per due activity nessun problema, per l'activity sulla Fi-Pi-Li_Si ho
quel problema descritto.
Grazie ancora e ciao
Go to Top of Page

AndrE424
Starting Member

Italy
40 Posts

Posted - 23/03/2022 :  14:42:21  Show Profile  Reply with Quote
Ciao,
ottimo, a mio modesto parere è più semplice e snello TSRE, ma non importa.

Presumendo che quando hai inserito i treni AI hai anche selezionato le vari fermate che devono fare, devi andare nella finestra della gestione del tuo traffico. Ti si apre l'elenco di tutti i treni AI. Selezioni quello interessato e ti sia apre un altra finestra dove vedrai l'elenco delle stazioni e gli orari, e selezioni la celletta dell'orario di arrivo e la modifichi a tuo piacimento. Poi selezioni le varie fermate con la spunta a sx e premi ricalcola questo. In base alle impostazioni previste dallo scenario ti ricalcolerà il tempo di fermata. Se lo vuoi modificare ulteriormente bisogna lavorare direttamente sul file traffic, quello con estensione .tfr. Ricorda che TS ragiona in secondi quindi per lui la giornata è formata da 86400 secondi.
Non voglio però confonderti le idee, quindi la modifica direttamente sul file del traffic, la terrei come ultima spiaggia.

Con TSRE è più semplice e modifichi in maniera più veloce e snella tutto quello che vuoi.

Ciao

Andrea V.
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  15:42:14  Show Profile  Reply with Quote
Grazie
ok, questo in MSTS AE lo sapevo fare, infatti ho ripreso di nuovo l'activity da zero, l'ho modificata, l'ho salvata e provata in OR
incroci e sorpassi ok, ma non si vedono accesi i segnali, sono tutti spenti, mah
va bene dai, non voglio disturbarti ancora, grazie di tutto e ciao
Go to Top of Page

AndrE424
Starting Member

Italy
40 Posts

Posted - 23/03/2022 :  16:33:12  Show Profile  Reply with Quote
Ciao,
mica disturbi. Non siamo mica in una telefonata. Si risponde quando si riesce....

Sul perché i segnali restano spenti, mi resta un mistero pure a me. Ma dal track monitor cosa vedi?
Puoi postare degli screen?

Ciao

Andrea V.
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  17:02:32  Show Profile  Reply with Quote
ciao Andrea, ma come si fa a inserire l'immagine nel post?
Go to Top of Page

renzo428
Forum Admin

Italy
1294 Posts

Posted - 23/03/2022 :  17:12:30  Show Profile  Reply with Quote
Ciao a tutti,
non sono stato molto presente sul forum perché ero fuori per lavoro.
Non sono molto dentro le activity, mi diverto di più a creare rotabili e scenari e Andrea ne sa sicuramente più di me.
I segnali spenti sono una sorpresa anche per me, nel caso dovresti mettere il file log sul forum.
Purtroppo su questo forum (è del 2000) non si possono aggiungere le immagini, devi salvarle su qualche sito pubblico e poi mettere il link.
Ho provato a fare un upload ma si perderebbero tutti i vecchi messaggi, come è già accaduto.

un caro saluto, renzo.
Go to Top of Page

AndrE424
Starting Member

Italy
40 Posts

Posted - 23/03/2022 :  17:36:02  Show Profile  Reply with Quote
quote:
Originally posted by randrett

ciao Andrea, ma come si fa a inserire l'immagine nel post?



Io uso https://imageshack.com/

Andrea V.
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  18:45:09  Show Profile  Reply with Quote
ciao Andrea e Renzo,
ecco qui il link per l'immagine


scusatemi ma sono prorpio newbie con OR, dove lo trovo il file .log richiesto da Renzo?
Grazie e ciao

EDIT visualizzata l'immagine
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  19:41:06  Show Profile  Reply with Quote
ciao, alla chiusura di OR dopo aver giocato all'activity incriminata mi da questo messaggio:

Open Rails 1.4
---------------------------
System.NullReferenceException: Riferimento a un oggetto non impostato su un'istanza di oggetto.

in Orts.Viewer3D.Processes.LoaderProcess.Load() in C:\Jenkins\jobs\Open Rails Stable\workspace\Source\RunActivity\Viewer3D\Processes\LoaderProcess.cs:riga 160

in Orts.Viewer3D.Processes.LoaderProcess.DoLoad() in C:\Jenkins\jobs\Open Rails Stable\workspace\Source\RunActivity\Viewer3D\Processes\LoaderProcess.cs:riga 140

---------------------------


può essere utile
Ciao e grazie
Go to Top of Page

randrett
Starting Member

Italy
26 Posts

Posted - 23/03/2022 :  19:44:18  Show Profile  Reply with Quote
"può essere utile" è una domanda, non un'affermazione, mi è scappato il punto interrogativo, scusatemi
Go to Top of Page

renzo428
Forum Admin

Italy
1294 Posts

Posted - 23/03/2022 :  20:36:33  Show Profile  Reply with Quote
Ciao Roberto,
per il file log devi aver prima spuntato la casella in basso nella schermata iniziale di OR (vedi immagine)



in questo modo all'avvio di OR salva il file OpenRailsLog.txt sul desktop.

Purtroppo questo file non consente di allegare file per cui devi copiare il contenuto ed incollarlo su un post premendo prima il tasto con il #, questo inserisce il comando code e /code compresi tra parentesi quadre che permettono di visualizzare come sotto quello che srivi nel mezzo.


his is a log file for Open Rails. Please include this file in bug reports.
--------------------------------------------------------------------------------
Date/time  = 22/03/2022 21:40:46 (2022-03-22 20:40:46Z)
BIOS       = BIOS Date: 06/09/13 10:58:25 Ver: 04.02 (American Megatrends Inc.)
Processor  = Intel(R) Core(TM) i3-3240 CPU @ 3.40GHz (4 threads, 2 cores, 3,4 GHz) (L1-Cache 128 KB) (L2-Cache 512 KB) (L3-Cache 3072 KB)
Memory     = 7,9 GB
Video      = NVIDIA GeForce GT 620 (1,0 GB RAM) (nvlddmkm 9.18.13.623)
Display    = \\.\DISPLAY1 (1920 x 1080, 32-bit, primary, 0 x 0)
Sound      = NVIDIA High Definition Audio (nvhda64v 1.3.18.0)
Sound      = Realtek High Definition Audio (rtkvhd64 6.0.1.6767)
Sound      = NVIDIA High Definition Audio (nvhda64v 1.3.18.0)
Sound      = NVIDIA High Definition Audio (nvhda64v 1.3.18.0)
Sound      = NVIDIA High Definition Audio (nvhda64v 1.3.18.0)
Disk       = C: (Disco rigido locale, NTFS, 894,2 GB, 558,9 GB free)
Disk       = D: (Disco CD-ROM, )
Disk       = E: (Disco rigido locale, NTFS, 1863,0 GB, 355,5 GB free)
OS         = Microsoft Windows 7 Home Premium  64 bit (6.1.7601)
Runtimes   = 2.0.50727 SP2  3.0 SP2  3.5 SP1  4 Client  4 Full  4.0 Client 
Runtime    = 4.0.30319.42000 (32bit)
\\.\DISPLAY1 = NVIDIA GeForce GT 620
--------------------------------------------------------------------------------
Version    = 1.4
Build      = 0.0.7962.28256 (2021-10-19 15:41:52Z)
Logfile    = C:\Users\UTENTE\Desktop\OpenRailsLog.txt
Executable = RunActivityLAA.exe
Argument   = -start
Argument   = -explorer
Argument   = C:\Program Files (x86)\Microsoft Games\Train Simulator\ROUTES\FiBoDD2000\PATHS\Auto.pat
Argument   = C:\Program Files (x86)\Microsoft Games\Train Simulator\TRAINS\CONSISTS\000.con
Argument   = 6:00
Argument   = 1
Argument   = 0
--------------------------------------------------------------------------------


Stessa cosa per le immagini, premendo il tasto con l'icona gialla prima del tasto # e inserendo il link puoi visualizzarla nel forum.

un caro saluto, renzo.
Go to Top of Page

renzo428
Forum Admin

Italy
1294 Posts

Posted - 23/03/2022 :  20:46:26  Show Profile  Reply with Quote
Per quanto riguarda i segnali in questo scenario, avevo pubblicato una pach che li rendeva compatibili con OR, la trovi nella pagina degli scenari di epoca IV insieme al download dello scenario stesso.

un caro saluto, renzo.
Go to Top of Page
Page: of 3 Previous Topic Topic Next Topic  
Next Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
ildeposito © 2000-20 ildeposito Go To Top Of Page
Powered By: Snitz Forums 2000 Version 3.4.07